Pascal. Задача 8-4

Задана логическая функция F(a, b) = ¬a b. Вывести таблицу истинности функции F(a, b).

Необходимо для каждого набора аргументов вычислить и вывести значение функции. Для преобразования логического значения в целое можно воспользоваться функцией Integer. Для обратного преобразования функции нет.

Решение

Для преобразования логического значения в целое можно написать функцию. В программе же использована операция сравнения с нулем.

var
  i, j : integer;
  a, b, F : boolean;
begin
  Writeln('a':3, 'b':3, 'F':3);
  for i := 0 to 1 do
    for j := 0 to 1 do begin
      a := i <> 0;
      b := j <> 0;
      F := not a or b;
      Writeln(i:3, j:3, Integer(F):3);
    end;
end.